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UNIT 1
MS Excel

Revision
What is MS Excel?
 MS Excel is spreadsheet program used for performing calculations on data and advanced
features like filtration, sorting, searching etc.
 MS Excel file is called workbook and this file consist of number of sheets.
 MS Excel file format is .xls
What are columns and columns header?
Vertical lines are called ‘columns’ in excel and each column has specified name called ‘column Header’.
Like (A, B, C…………. Z…. AA,AB..)
There are 16384 columns in one sheet.

What are Rows and Row headers.?
Horizontal lines are called “Rows” in excel and each row has a specified name which is called “Row
header” like (1,2, 3….) there are 10,48,576 rows in one sheet.
What are Cells?

Intersection point of row and column in called ‘cell’.

What is cell address?

Combination of column name and row name make “cell address” like column A and Row 100 will
make cell A100.
What is name box?
The cell address of the active cell is shown in the name box which is on top left side.
What is Sheet tab?
In excel each sheet has a specified name like sheet1, sheet 2 known as sheet tab, we can change sheet
name and insert or delate sheets.
What is the difference between sheet and the workbook?
Combination of cell is called “sheet” and combination of sheets is called “workbook”.
What is Range?

More than two selected cells are called “Range” like (A1: A10)

How can we insert / delete column / Row?

Home >cell >insert /delete (row or column).
How can we create name of range?
Yes, we can, select cells >Type name in name box > press enter.
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What are operators?
Specified signs to perform specified actions are called ‘operators’.

How many types of operators are there?
There are two types of operators:
1.Arithmatic operators:
Sign Name

Description

+

Plus

used for addition of numeric values.

-

minus

used for subtraction.

*

Asterisk

multiplication between numeric values

/

forward slash

Used for division

^

Exponentiation

To create power

2. Logical (comparison) operators
Sign
=
>
<
>=
<=
<>

Name
Equal to
Greater than
Less than
Greater than or equal to
less than or equal to
not equal to

What is a Formula?
Any expression created by the user is called a ‘Formula.’
There are two parts of any formula.
1. Operand: cell name is called operand like A1, B6, D3, G6 etc.
2. Operator: like =, +, -, etc.
Eg.= 5000 +500 =? Or =A1 + B1 -?
What is a function?
Predefined equations are called ‘Function’ like = Sum, = count, =Max etc.

There are three parts of any function:
1.operand
2.operator

3.Function name: Sum, count, maximum, min. etc.
Each function or formula will start with an equal to (=) sign.
Functions:
Sum used for addition, just numeric values and ignore test values:
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= Sum (Number 1,2,3, 4……….)
=Sum (cell 1: cell 2)

Max Shows largest number in the range and ignores text values.
=max. (Number1,2, 3,)
=max. (cell1: cell2)
Min Shows smallest values in the range and ignores test values:
=min (Number1,2,3. …….)
=min (cell1: cell2)

Average Return average of the given range:
=Average (
=Average (
Count: used to count the number of cells which have a values:
= count (
=count (
Count A: used for a count of all values (text numbers and special characters.
=countA (
=countA (
Count blank: used to count just blank cells:
=Count blank (San tosh)
=Count blank (cell1: cell2)
Countif: counts the number of cells with a range that meets a given condition:
=Countif (Range, “criteria”)

=Count if (cell1: cell2., “operator --value.”)

What is a series operation?

This is used to create series of number, date etc.
Home > Edit >Fill >Series> column/ row
Line

growth

Date

Autofill

What is custom list?
Office button >Excel option >Popular
-

Edit custom list >import >
Add / delete > ok.
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ADVANCED EXCEL
CELL REFERENCING
The cells are referred by column alphabet followed by row number. What is cell referencing? These cell
coordinates which refer to a cell are known as cell referencing.
These are:
Relative Referencing
Absolute Referencing
Mixed Referencing
RELATIVE CELL REFERENCING
When a formula involving cell addresses is copied to another cell, the relationship between the cells referred
to in the formula and the cell where the formula is stored is preserved by modifying the now and column. This
feature is termed as Relative Referencing
ABSOLUTE CELL REFERENCING
Absolute referencing always point to exact one address. In this type of referencing, excel doesn’t update the
cell references on copying or moving the formula
To create an absolute cell reference put a $ (dollar) before the parts of the formula (column, row) that you
want to keen absolute.
For example $c$6 is an absolute cell address
MIXED REFERENCING
The combination of relative and absolute cell referencing is known as Mixed cell referencing. A cell address
contains two parts- Column- letter and Row- number. If you put $ sign before both parts i.e. column-letter and
row number, the cell address become absolute.
For instance, C$6. If a formula having mixed cell address gets copied only the relative part of it gets updated.
FILTERING DATA
It is a facility whereby from a large list only a subset of records can be selected and viewed the meet a certain
criteria condition specified by the user. Excel provides an Auto Filter to handle simple criteria and Advanced
Filter to handle complex criteria which is discussed below.
Filtering Data Using Auto Filter:
When the command is activated, Excel places dropdown across for each column. By clicking on one o the
arrows, all unique values for that particular column are displayed. A criteria is then set by selecting any items
from the list
“ADVANCED FILTER”
When the criteria have to be give on more than one field at the same time, the advanced filter is used. The
advanced filter command, requires the following three ranges to be specified.
1. List Range: The range of cells containing the data to be used for filtering.
2. Criteria Range: The range of cells containing the criteria for filtering.
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3. Copy to: The range where filtered records need to be stored. This is to be specified only if the filtered
records need to be extracted on the separate area.
Conditional Formatting
MS Excel allows you to highlight specific data entries with a unique formatting (i.e. font size, font color,
etc.) Suppose you have created a database of result of 100 students in final exams. You want to highlight
one by one, it will take a lot of time. Moreover, there are chances of mistakes. Conditional Formatting
allows you to just specify the rule, ret leave up to it.
Confused? Let us understand it with the help of an example.
In the following worksheet, we can apply the conditional formatting to highlight the percentage of students
less than 50 percent.
1
2
3
4
5
6
7
8
9
10
11
12
1.
2.
3.
4.
5.
6.
7.
8.
9.

A
B
C
D
Name
Marks Obtained Total Marks Percentage
Amit
348
700
50%
Sunil
538
700
77%
Sushil
403
700
58%
Rajan
338
700
48%
Aditya
573
700
81%
Banita
178
700
39%
Adut
648
700
92%
Nirvan
938
700
91%
Jakeer
237
700
33%
Puneeta
433
700
61%
Abhisasha
683
700
97%
Select the entries in the Percentage column.
Click on Home tab.
In the Styles group, click on Conditional Formatting.
A list of various formatting options will appear on the screen.
Click on Highlight Cells Rules> Less Than
Less Than dialog box will appear on the screen.
Type 50% in the Format cells that are Less Than box. Select Red Text option.
Click on.
All the values in the percentage column which are less than 50% will be displayed in red color
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A
Name

2
3
4
5
6
7
8
9
10
11
12

Amit
Sunil
Sushil
Rajan
Aditya
Banita
Adut
Nirvan
Jakeer
Puneeta
Abhilasha

B
Marks
Obtained
348
538
403
338
573
278
648
638
237
433
683

C
Total marks

D
Percentage

700
700
700
700
700
700
700
700
700
700
700

50%
77%
58%
48%
81%
39%
92%
91%
33%
61%
97%
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In this way we can format the entries in MS Excel based on some condition. There are many Conditional
Formatting options available in MS Excel
Conditional Formatting Options

Data Bars

Function
It highlights the cells according to rule you have
specified. You can highlight cells based on the
rules less than. Greater than, Equal to, Between,
etc.
This option allows you to highlight the specific cell
entries based on some criteria. For example: You
can highlight top items: Top 10%, Bottom 10
items, Bottom 10%, Above Average and Below
Average.
This option displays the selected cells with the
colored data bars.

Color Scales

This option represents the selected cells with
different shades and colors.

Highlight Cells Rules

Top/Bottom Rules

Protecting the Worksheet.
Sometimes users accidentally or deliberately delete or modify the important data in MS Excel sheet. To
prevent the users from making accidental changes, you can protect your worksheet elements with a password.
When you apply a password to the worksheet, by default all the elements of worksheet got locked. Only the
users having the password can modify the worksheet elements.
Data Validation:
You can decide and restrict the data entries in specific cells based on what should be allowed to enter and what
should not be allowed to enter in the cells.
For Example: Suppose, you want to enter marks between 1 to 100. For this, you can use the data validation
feature of MS Excel where you can restrict the entries from 1 to 100. If value less than 1 or greater than 100
is entered in the cells, then it will show an error message.
To do so, follow the below given steps.
1. Select the range of cells C2 to C6.
2. Click on Data Validation in the Data Tools group on the Data tab.
3. Select Data Validation from the drop down menu.
4. Data Validation dialog box will appear on the screen
5. By default, Settings tab is selected. In the Allow: box, select whole number.
6. Type 0 in the Minimum: box.
7. Type 100 in the Maximum: box.
8. Now click on Input Message tab. In the Title: box, type Data Validation.
9. In the input message: box, type enter value either>=0 or <=100.
10. Now click on Error Alert tab.
11. In the Error message: box, type input is wrong and beyond the prescribed limit.
12. Click ok
Now, whenever anybody tries to enter the value in the selected cells beyond the prescribed limit.
Error message will appear on the screen.
Click on Retry button, to enter another value.
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Goal Seek
This is a powerful feature of MS Excel which helps you to get the desired result in the cell containing formula.
It changes the input value in the cell to get the desired result. Let us understand this with the help of an
example. Type the following data entries in MS Excel Worksheet
1
2
3
4
5
6
7
8

City
Ahmedabad
Delhi
Mumbai
Ludhiana
Bihar

Year
2016
2016
2016
2016
2016
Total

Sale
208
304
222
343
343
1420

Suppose, you already know that the total sale is 1500. Total Sale is calculated using formula =SUM(C2:C6)
in C7 cell. But you are unsure about the sale made in Mumbai. So you can apply the Goal Seek feature in C7
cell. This can be done as follows:
1.
2.
3.
4.
5.
6.

Click on What-if Analysis in the Data Tools group on the Data tab.
Select Foal Seek… from the What-If Analysis drop down list.
Goal Seek Dialog box will be displayed on the screen.
Type C7 in the Set Cell: text box.
Type 1500 in to value text box.
Click on By changing cell: text box and then select the cell C4. Its address will appear in the By
changing cell: text box.
7. Click Ok.
8. The value in the C4 Cell will change in such a way that you get target result. It will change to 302 so
that the total becomes 1500.
9. Goal Seek Status dialog box will appear on the screen. Click OK if you are satisfied with the changed
value in C4 cell. If you do not want to change the value on C4 cell, then click Cancel.
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UNIT-2
Introduction to Programming Language
Language

LLL (LOW LEVEL LANGUAGES

Binary / Machine
computer language

Assembly language

HLL (HIGH LEVEL LANGUAGES

3GL (Third Generation
language) or
(Procedural
Language) Eg. LOGO,
BASIC, COBOL etc.

4GL. (Fourth Generation Language
or OOPS (Oriented programming
language) Eg. BlueJ, C++, Java etc.

Q1. What is the difference between high level language and low level language?
Ans.
HLL
LLL
1. It is machine independent 1.It is a machine dependent language.
language
2. It is portable i.e. , it can be
carried from one
computer to another via
secondary storage device
like CDs, Pen drive

2. It is not portable.

3. Eg- C++, Java, Python etc.

Eg- Machine languages, assemble
language

Q2. What is assembly language?
Ans. Assembly language is a LLL in which we use mnemonics
eg. ADD - A,B
STORE C
meaning that the values of A,B are added and stored in variable C.
Q3. What are 4 GLS?
Ans. 4 GLS or Fourth Generation Languages place more importance on data rather than on the
procedure of programming. Eg- C++, Java
Units of Memory
1 bit
=
4 bits
=
8 bits /2 nibbles =
210
=
210
=
10
2
=
210
=
10
2
=

0 or 1 (binary digit)
1 nibble or ½ bytes
1 byte
1024 bytes
1024 KBs
1024 MBs
1024 GBs
1024 TBs

= 1 KB (Kilo Byte)
= 1 MB (Mega Byte)
= 1 GB (Giga Byte)
= 1 TB (Terra Byte)
=1 ZB (Zeta Byte)
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OOPS
OOPS – Object Oriented Programming System.
Definitions: - Object are real world entities or items which have some characteristic and behavior.
Eg:- Orange
Characteristics
Behaviour
1. It is orange in colour
1. It is juicy.
2. It is spherical in shape
2. It has a sweet - sour taste.
3. It has a tangy smell
Class- It is a group of objects that have the same properties, common behaviours & relationship i.e.
a class is a collection of objects of similar types. For eg. Mango, apple, orange are objects of
class fruits.


OOPS (Object Oriented Programing System) : It is the process of breaking down a large
problem into smaller problems that are easier to understand.



Property /attributes / characteristics : The characteristics of an object are represented as
variables in a class. Eg: Each student in a class has a name, age and address.



Methods: The action performed on an object are called methods. Eg: admissions, examination,
tests are methods in a class student.



Platform Independence:
A platform is the hardware or software environment in which a program runs. So if a program
can run in any environment/Operating System, then it is said to be platform independent.
Eg: Blue J : Blue J is a platform independent language because it can run on any kind of
operating system.



Algorithm: Step by step instructions written in a simple language (like English) to solve a
given problem.
Flowchart: Pictorial/ Graphical representation of any algorithm is a flowchart.



Programing in Blue J
Step by step instruction written in a HLL to solve a given problem.
1. */Blue J Example 1 */
2. *To display the biodata of a student*
3. class Biodata
4. {
5.
public static void main ( )
6. {
7.
System.out.println(“Roll no : 21”);
8.
System.out println(“Name: Navya”);
9.
System.out.println(“Class: 7A”);
10.
}
11. }
Explanation




Statement 1 & 2 are comments in Blue J which explains the purpose of the program.
Statement 3 specifies the name of the class.
Statement 4 indicates the begin of the class.
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Statement 5 defines the main function where the execution begins.
Statement 6 shows the opening bracket of the main body of the program.
Statement 7,8 & 9 are used to print the information of the student written in double quotes.
Statement 10 closes the main body of the program.
Statement 11 closes the class.
Blue J
WABJP to print N
NA
NAV
NAVY
NAVYA

/*To print the name pattern*/
class pattern
{
public static void main ( )
{
System.println (“N”) ;
System.println (“NA”) ;
System.println (“NAV”) ;
System.println (“NAVY”) ;
System.println (“NAVYA”) ;
}
}
Blue J
Step for making a program
1. What output is needed?
Sum , average.
2. What input are needed?
A, B, C
3. How to manipulate the input so that proper output is got? (use BODMAS)
Sum= A+B+C
Average = sum/3 or (A+B+C) /3
4. To print the output
Print sum
Print average
/*To find sum & average of three numbers*/
class calculate
{
public static void main ( )
{ int A,B,C sum ;
float average;
A=10 ;
B=5 ;
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C=50;
Sum = A+B+C ;
average=sum/3;
System.out.println (sum);
System.out.println(average);
}
}
Write a Blue J program to find the sum, difference, product & dividend of 2 nos.
/*To print sum, difference, product & dividend of 2 nos. class calculate*/
class calculate
{
public static void main ( )
{
int a, b, sum, difference, product;
float dividend ;
a=100 ;
b= 10 ;
sum = a+b ;
difference = a-b ;
product = a *b ;
dividend = a/b ;
System.out.println(“The sum=”+sum) ;
System.out.println(“The difference”+difference) ;
System.out.println(“The product=”+product) ;
System.out.println(“The divident=”+divident) ;
}
}
Write a Blue J program to find the Simple Interest.
/*To find simple interest*/
class simple
{
public static void main ( )
{
float p, r, t, si ;
p=1000 ;
r= 2.5;
t= 3.5;
si = p*r*t/100 ;
System.out.println(“The simple interest is” + 5) ;
}
}
Write a Blue J program to calculate the area and perimeter of circle.
/*Calculate the area & perimeter of circle*/
class Circle
{
public static void main ( )
{
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double pi, m, area, peri ;
pi =3.14 ;
m =10 ;
area = pi*r*r ;
peri = 2*pi*m ;
System.out.println(“the area=” + area);
System.out.println(“perimeter=”+peri);
}
}
Write a Blue J program to find area and perimeter of a square.
/*To find area and perimeter of a square*/
class square
{
public static void main ( )
{
double side, area, perimeter;
side = 5;
area = side *side;
perimeter = 4*side;
System.out.println(“Area of a square=” +area) ;
System.out.println(“Perimeter of a square=”+ perimeter) ;
}
}
Write a Blue J programme to find area and perimeter of a rectangle.
/*To find area & perimeter of a rectangle*/
class rectangle
{
public static void main ( )
{
double length, breadth, area, perimeter;
length = 40 ;
breadth = 20 ;
perimeter = 2* (length + breadth) ;
area = length * breadth ;
System.out.println(“Area of rectangle=” + area);
System.out.println(“Perimeter of rectangle=” + perimeter) ;
}
}
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IF – ELSE
It is a conditional statement
Relational Operators: Those operators which are used to establish a relation between two variables
and
to give the answer in true or false are called relational operators. Namely,
> greater than
< less than
< = less than equal to
>=greater than equal to
= = equal to
< > / ! = not equal to
Syntax :
if (condition)
{
S1 ;
}
else
{
S2 ;
}
Flow chart

If
(condition)
?

True
S1

False
S2

Q1. Write a Blue J program to find the greater of two number
/*To find greater of 2 numbers*/
class great
{
public static void main ( )
{
int a, b ;
if (a>b)
{
System.out.println(a+ “is greater”) ;
}

End
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else
{
}
}

System.out.println (b+ “is greater”) ;

}
Q2. Write a blue J program to input age of a person and to print if person can vote or not.
/*To find if a person can vote or not*/
class vote
{
public static void main ( )
{
double age ;
if ( age> = 18)
}
System.out.println (“jCan vote”) ;
}
else
{
System.out.println (“Cannot vote”) ;
}
}
}

UNIT 3
DRAWING WITH FLASH
FLASH TOOLBARS
STANDARD TOOLBAR
Standard toolbar contains shortcuts of standard menu commands such a Open, Print, Copy,
Paste etc.
STATUS TOOLBAR
Status toolbar displays the Status bar that provide the information about commands, buttons
and the state of the Caps and Num Lock Keys.

CONTROLLER TOOLBAR
Controller toolbar displays the Controller as part of the Standard toolbar. Its functionality is
quite similar to VCR playback system. You can use Play, Stop, Step, Forward and Step Backward
buttons to browse through the frames of the animation.
DRAWING TOOLBAR
Drawing toolbar displays the toolbox that contains the Flash drawing tools and their modifiers.
As it is the most important toolbar in Flash, let us discuss its tools in details. Flash provides you
different tools. Toolbox contains the basic tools used to create new images and text. The
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Toolbox includes all of the drawing tools, The Text tool, and the Color for both lines and fills.
Drawing Toolbar include:
(ARROW)SELECTION

LINE
BEZIER PEN
OVAL
PENCIL
INK
EYE DROPPER

DRAG HAND

SUBSELECTION
LASSO
TEXT
RECTANGLE
BRUSH
PAINT BUCKET
ERASER

MAGNIFICATION

STROKE
FILL COLOR
BLACK & WHITE

SWITCH STROKE & FILL

CONTEXT SENSITIVE TOOL
MODIFIERS

PANELS
Many of the functions in Flash 4 that were in dialog boxes or other windows have been placed
into panels. You can organize panels just about any way you want. From the default Panel set,
You can drag any of the tabs into a separate panel away from the set. If you want to view more
than one tab in a panet set, pull off those you want to view separately.
INFO
It contains the information about the position of an object on the stage as well as its height
and width, its color, and the position of the cursor. The default zero point (X=0, y=0) is at the
upper – left corner of the stage, but by clicking the middle box, the center of the stage
becomes the zero point. All the drawings and symbols can be positioned and resized using this
panel.

FILL
The Fill panel provies a place to make adjustments to color and pattern fills for objects.
Gradients like Linear and Radial can be adjusted and added to the color swatches. Gradients
like Linear and Radial can be adjusted and added to the color swatches.
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Fill panel has a menu with selections that use to be in the Toolbox.
STROKE
The stroke panel is used to adjust the width of drawing line and outline shapes. The stroke
panel is where you adjust the width of drawing lines and shape outlines.

TRANSFORM
The transform panel is used for changing the size of objects and skewing them to different
shapes.

ALIGN
All options for alignment and distribution of objects are in the Align panel. Selected objects
and aligned relative to one another or to the stage.

MIXER
The new color mixer allow several different options, including the color mixing systems in
Windows and any other operating system.
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SWATCHES
The swatches panel contains color swatches used for selecting line and fill colors.

PARAGRAPH
The Paragraph panel is used to format text for alignment, tracking, keming, and baseline shift.

TEXT OPTIONS
It is important because it contains the modification options for text fields; these options are
part of the Toolbox. If you plan to make forms with Flash, this panel is important you can use
text options panel with a variable name for a text field.

EFFECT
In the Effect panel’s pop-up menu, you can change Brightness, Alpha (transparency), Tint, or
Advanced (color mixes). However, you can change only one item on the effect panel menu.
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FLASH COLORS
Every Flash File contains its own color palette, which is stored inside the Flash file. The user
can import and export both solid and gradient color palettes between Flash fields, as well as
between Flash and other application, such as Macromedia Fireworks and Adobe Photoshop.
Flash displays the colors in a file’s palette and color window. You can use the Colors window
to import, export, and modify a file’s color palette.
The flash color window on the panels work in concern with one another. If one changed, all
are changed. This list indicates how colors are related to each features:
Toolbox---------Stroke, fill color and system colors.
Fill Panel---------Fill and radial colors.
Mixer panel------System colors, RGB in decimal and hexadecimal, HSB (Hue, Saturation,
Brightness) in percentage, and alpha transparency as a percentage.
Character Panel---Color of currently selected text. The text color takes the fill instead of the
stroke color.
Swatches panel---Swatches of color plus radials.
Stroke panel-------Color of all stroke lines.
ASSIGNMENT
1. Write the functionality of the following toolbars:
a. Standard Toolbar.
b. Status Toolbar
c. Controller Toolbar
2. Drawing Toolbar
3. What do you mean by Panel?
4. Explain different types of Panel.
5. What are the different types of Aligns in Paragraph Panels.
6. Explain the various options in EFFECT Panel.
7.
ACTIVITY
Try creating your own color. How can you edit it further? Write the steps you followed.

IMORTING GRAPHICS
Because graphics created in other applications—such as Macromedia FreeHand or Fireworks
and Adobe Illustrator or Photoshop ---are common sources for Flash 5 media, it’s important
to understand how to import those graphics.
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Likewise, graphics from scanned artwork is another source of drawings that must be imported
and used in Flash 5.
Importing file formats: Flash 5 can import different file formats depending on whether
QuickTime4 or later is installed. Using Flash with QuickTime4 installed is especially useful for
collaborative projects in which authors work on both Window and Macintosh platforms.
QuickTime4 extends support for certain file formats (including Adobe Photoshop, PICT,
QuickTime Movie, and others) to both platforms.
The easy part is importing the graphics. Here’s how:
1. Select FileImport.
2. In the Import dialog box, choose a file format from the Show pop-up menu.
3. Navigate to the desired file and select it. If an imported file has multiple layers,
Flash might create new layers. Be sure the Timeline is visible when importing a file
with multiple layers.
The following are the file formats that can be imported in Flash 5, regardless of
whether QuickTime4 is installed:
FILE TYPE
EXTENSION
Adobe Illustrator
.esp, .ai
Bitmap
.bmp
GIF and Animated GIF
.gif
JPEG
.png
Flash Player
.swf
Flash lets you move, delete, transform, stack, align, and group objects. You can also
link an object to a URL.
The following file formats can be imported into Flash 5 only if QuickTime4 is installed.
FILE TYPE
EXTENSION
PICT
.pct, .pic
MacPaint
.psd
Note: Modifying lines and shapes can alter other lines and shapes on the same layer.
There are two main types of Image/Graphic files.
Bitmap (or raster) images are stored as a series of tiny dots called pixels. Each pixel is actually
a very small square that is assigned a color, and then arranged in a pattern to form the image.
When you zoom in on a bitmap image you can see the individual pixels that make up that
image. Bitmap graphics can be edited by erasing or changing the color of individual pixels using
a program such as Adobe Photoshop.
File size is usually very large.
These graphics suffer in quality if resized.
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Vector Graphics- Unlike bitmaps, vector images are not based on pixel patterns, but instead
use mathematical formulas to draw lines and curves that can be combined to create an image
from geometric objects such as circles and polygons.
Vector images are edited by manipulating the lines and curves that make up the image using
a program such as Adobe Illustrator.
Vector images have some important advantages over bitmap images. Vector images tend to
be smaller than bitmap images. That’s because a bitmap image has to store color information
for each individual pixel that forms the image. A vector image just has to store the
mathematical formulas that make up the image, which take up less space.
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FLASH LAYERS
Whenever you create a new Flash movie, it contains one layer. You can add more layers to
organize our artwork and animation in the movie. We have already understood the concept
of layers.
Flash provides three types of layers namely Normal layer, Guide Layer and Mask Layer. Flash
uses different symbols to represent these layers.
In the figure
Layer 1 – Normal
Layer 2 - Guided
Layer 3 - Guide layer for Layer 2
Layer 4 – Masked
Layer 5 – Mask (Masking the Layer 4)

A flash layer is like a piece of glass i.e. a part of stack and the object we put on each layer, can
be considered to place on each piece of glass.
You can either create these layers by simply configuring the setting of the layer in the layer
properties dialog box or by selecting options from Context menu.
TYPES
1 Normal: This layer type is a default layer type, on which one can draw images and objects
and also animate the same.
2 Guide: This layer is used to create grids, backgrounds, or other objects to help the user to
align the artwork. You can link several normal layers to a Guide layer. However, it does not
appear in the final movie.
3 Guided: This is a normal layer that is linked to a guide layer. Several Normal layers can be
linked to a guide layer.
4 Mask: This layer allows you to mask/hide any layers linked to it. Only certain portions of the
underlying layer appear through the mask design, while other parts of the layer are hidden or
masked. This is used for creating effects such as spotlights.
5 Masked: This layer is a normal layer that is linked to a mask layer.
Layer Height: It allows you to set (100%, 200%, or 300%) the layer height as per your
requirement. It is useful for viewing sound waveforms in detail.
GUIDELAYER
Guide layer helps you in drawing by keeping the layout of the movie consistent or in tracing
the images, drawing, etc. A guide emblem appears next to the Guide layer name. Guide layer
do not appear in a published Flash Player movie, that is they are only visible in Movie Edit
mode.
Once you have selected the Guide option, a tick mark appears next to the Guide option to
indicate its selection as shown in figure above.
MASK LAYER
The Mask layer allows you to hide objects and images on the layer linked to the mask layer,
except the portion that you have covered with a filled object. A filled shape or type object on
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the mask layer creates a gap through which the contents of layers underneath are visible.
Mask layers can contain only a single shape, instance or type object.
Steps to create a Mask Layer.
1 Create a layer and then draw or import the contents you want to show through a gap in the
mask.
2 Select the layer you have created and then select Layer option from the insert menu to
create a new layer above it. Since the mask layer always masks the layer immediately below
it, your mask layer should always be placed below the mask layer.
3 Draw a filled shape, or create an instance of symbol on the mask layer. Flash ignores bitmaps,
gradients, transparency, colors, and line styles in a mask layer. The filled area will appear
transparent in the masked layer and the non-filled area will appear opaque.
4 Right-Click on the mask layer’s name in the Timeline and choose Mask option from the
Context menu. Once you select Mask Option, a thick mark appears next to the Mask Option
to indicate its selection as shown in figure below.
ASSIGNMENT
1. What do you mean by Flash layer and What are the different types of it?
2. Which layer is used to create Grids and Backgrounds?
3. What is the difference between Guided and Mask Layers?
4. In which mode Guide Layer is visible?
5. Write the different steps to create a different mask layer.
ANIMATION BASICS
UNDERSTANDING ANIMATION TECHNIQUES
Before you start animating your drawing, let’s review a few basic concepts of animation so
that you’ll understand the different tools Flash provides.
The essence of animation is an optical illusion. A succession of drawings is made, with slight
changes between each drawing. When these drawings are shown in rapid succession, the
human brain automatically perceives movement. A very simple form of animation is a flipbook, with a drawing on each page. When you flip rapidly through the book, it gives the effect
of motion. This is an animation.
Each of the individual drawings in an animation is called a f r a m e . The Timeline in Flash
shows the sequence of frames in your animation.
K e y f r a m e s are an important element in creating Flash animations. Imagine a single
animation sequence as a short trip from your house to the grocery store.
To give directions, you would probably mention the important intersections. You might say:
“Go to the first stop sign and take a right. Then, when you get to Maple Street, go left.” And
so on. Think of keyframes as the intersections, or turning points, of your animation sequence.
The two styles of animation involve different uses for keyframes. In the first type of animation,
called f r a m e - b y - f r a m e animation, every single frame is a keyframe. This method is
often laborious, but it gives you very fine control over your animation. The second type of
animation is more like giving the street directions we described above. This method, called t
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w e e n i n g , uses a beginning keyframe and an end keyframe, and relies on Flash to figure
out the frames in between (this “in-betweening” is why the process is called “tweening”).
You will start by making a frame-by-frame animation with your drawing of the sun. The goal is
to make the rays of the sun appear to pulse.
Creating a Frame-by-Frame Animation
It is the most basic form of animation in Flash. As it allows you to employ unique drawings in
each frame, it can be used for complex animations.
To create a frame-by-frame animation follow these steps:
1 Select a frame from where you want to begin frame-by-frame animation. When you add
second keyframe, you will note that the same picture or the drawing is appearing on it.
Select the drawing or the picture with the help of Arrow tool and delete the same. And
then, you can either draw or import the new picture or the image on it. Please note that
if it is not a keyframe, then make it a keyframe by inserting a new keyframe.
2 Repeat the process of adding new keyframe and importing or drawing the images
according to your requirement.
3 Finally, you can test the animation of each keyframe using Play option under Control
menu.
TYPES OF TWEENING
Flash can tween position, size, rotation and skewness of instances, groups and types. Flash can
also tween the color of instance and type effects by creating gradual color shifts or making an
instance fade in or out.
TWEENING IS OF TWO TYPES
Shape Tweening
This allows you to apply morphing effects to shapes between starting and ending keyframes
NOTE:- Shape tween can incorporate only shapes and not the groups, symbols or editable text.
Therefore, first convert such elements into shapes by configuring break apart setting, for them
with the help of Break Apart option under Modify menu.
SHAPE TWEENING
1) Click a layer name to make it the current layer and select an empty keyframe where you
want the animation to start.
2) Create the image for the first frame of the sequence.
3) Use any of the drawing tools to create a shape.
4) Create a second keyframe after the first frame.
5) Create the image for the last frame of the sequence. (You can tween the shape, color,
or position of the image created in step 2.)
6) Choose Window > Panels > Frame.
7) For Tweening, select Shape.
8) Click and drag the arrow next to the Easing value or enter a value to adjust the rate of
change between tweened frames:
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MOTION TWEENING
This allows you to implement animation in the terms of change in properties of instances,
groups and type. To tween the color of groups or type, convert them into symbols.
Whenever Flash encounters an image that is not a symbol. It automatically converts it to a
symbol and name it tween1,tween2, etc. This type of tweening is used to move an element
from one set of co-ordinates to another.
You can create a motion tween using one of two methods:
1) Create the starting and ending keyframes for the animation and use the Motion
tweening option in the Frame Properties panel.
To Create a motion tween using the Motion Tweening option:
a) Click a layer name to make it the current layer, and select an empty keyframe in the
layer where you want the animation to start.
b) Create an instance, group, or text block on the Stage, or drag an instance of a symbol
from the Library Window. To motion tween an object you have drawn, you must
convert it to a symbol.
c) Create a second keyframe where you want the animation to end.
d) Do one of following to modify the instance, group, or text block in the ending frame:
Move the item to a new position and modify the item’s size, rotation, or skew.
Modify the item’s color(instance or text block only). To tween the color of elements
other than instances or text blocks, use shape tweening.
e) Choose Window > Panels > Frame.
f) For Tweening, select Motion.
g) If you modified the size of the item in step 4, select Scale to tween the size of the
selected item.
h) Click and drag the arrow next to the Easting value or enter a value to adjust the rate
of change between tweened frames.
i) To begin the motion tween slowly and accelerate the tween toward the end of the
animation, drag the slider up or enter a value between – 1 and – 100.
j) To begin the motion tween slowly and accelerate the tween toward the end of the
animation, drag the slider down or enter a positive value between 1 and 100. By
default, the rate of change between tweened frames is constant. Easing creates a
more natural appearance of acceleration or deceleration by gradually adjusting the
rate of change,
k) To rotate the selected item while tweening, choose an option from the Rotate menu:
Choose None (the default setting) to apply no rotation. Choose Auto to rotate the object
once in the direction requiring the least motion. Choose Clockwise (CW) or
Counterclockwise (CCW) to rotate the object as indicated, and then enter a number to
specify the number of rotations.
2) Create the first keyframe for the animation, and then choose Insert > Create Motion
Tween and move the object to the new location on the Stage. Flash automatically
creates the ending keyframes.
To create a motion tween using the Create Motion Tween command:
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1. Select an empty keyframe and draw an object on the Stage, or drag an instance of a
symbol from the Library window.
2. Choose Insert > Create Motion Tween. If you draw an object in step 1, Flash
automatically converts the object to a symbol and assigns it the name tween1. If you
Draw more than one object, additional objects are named tween2, tween3 and so
on.
3. Click inside the frame where you want the animation to end, and choose Insert >
Frame.
4. Move the object, instance, or type block on the Stage to the desired position. Adjust
the size of the element if you want to tween its scale. Adjust the rotation of the
element if you want to tween its rotation. Deselect the object when you have
completed adjustments. A keyframe is automatically added to the end of the frame
range.
5. Select the keyframe at the end of the motion tween and choose Window > Panels >
Frame. Motion Tweening should be selected automatically in the Frame panel.
6. If you modified the size of the item in step 4, select Scale to tween the size of the
selected item.
7. Click and drag the arrow next to the Easing value or enter a value to adjust the rate
of change between tweened frames:
ASSIGNMENT
1. What are the three distinct types of frames?
2. Explain two methods for creating an animation sequence in Flash.
3. What is the advantage of Frame by Frame animation?
4. What are the different steps to create frame-by-frame animation?
5. Explain the word Tweening
6. How Flash distinguishes Tweening animation from Frame-by-Frame animation in the
Timeline ?
7. What are the different type of Tweens that we can do in Flash?
8. What do you mean by Shape Tweening and what are the different steps to create
shape tween?
9. What do you mean by Motion Tweening and How can you create a motion tween?

MACHINE ROOM SESSION
Convert a Circle to a Square using Shape Tweening. Create a triangular Kite Flying in the
Sky.
TEXT AND FORMS
USING TEXT IN FLASH
Flash provides you with Type and Text effects to communicate with the viewer. Flash 5 has
been packaged with Divice font support which means that you can use sans serif, sarif and
typewriter fonts which will be converted to the default fonts on the 2nd user’s computer.
Flash offers you different Text effects like Text with drop Shadows, Glowing text, and
Gradiant filled text.

26

CREATING TEXT
To place text blocks on the stage, you use the Text tool. You can place type on a single line
that expands as you type or in a fixed-width block that wraps words automatically. Flash
displays a round handle at the upper right corner of the text blocks that extend, and a square
handle for text blocks with a defined width.
Fixed Text
Block

Extended Text
Block Handle

Dynamic or input
Text Block Handle

Flash displays a square handle at the bottom right corner of editable text boxes, indicating
that you can size the text box vertically and horizontally according to the amount of text
entered.
THE TEXT OPTIONS PANEL
With the help of this panel you can establish Text Fields and Forms. The figure given below
shows how the Text Option panel appears when different types of text formats are used.
1 Static Text
2 Dynamic Text
3 Input Text
STATIC TEXT
Static Text is a default
text. This is the most
common Text. You can
use it for a labels, as
identifiers, a narrative,
or as a block of textual
instructions.
DYNAMIC TEXT
Dynamic Text is a text which can be modified by Flash while running is an SWF file. The user
cannot enter into a dynamic text window. For both the Dynamic Text and Input Text elections,
You can select the HTML check box is preserved when changed by the user. Included are the
following formats and their tags:
Hyperlink <A> as in <A href =
“www.cbse.nic.in”>
Bold
<B>
Color of font
<FONT COLOR>
Font
<Font Face> Arial or
Times
Font size
<Font Size> in HTML
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Italic
<I>
Paragraph <P>
Unordered list

<U>

By checking the HTML box, you preserve the rich text formatting in editable boxes. Preserving
the text formatting also means preserving the design.
GRAPHIC TEXT
Text is an object in its own right. It is dependent on the set of code in font set and not a bitmap
that you can change. Through Graphic Text you can modify text so that it changes from text
and type to a graphic like and other graphic.
BREAKING TEXT APART
Break apart applies only to outline fonts such as True Type fonts. Bitmap fonts disappear from
the screen when you break them apart. When you break text apart, you essentially turn it into
a graphic. You also have more control over it because you can make changes to it that you
cannot make to text. In other words, you can do anything to text that you can do by drawing.
ASSIGNMENT
1. When are the different text effect offered by Flash?
2. What is the advantage of text tool? Explain with example.
3. Give three differences between Static Text and Dynamic Text.
4. In which Fonts Breaking Text apart can be applied?

COORDINATED ANIMATION
SETTING THE SCENE
Till now, the animations have been fairly simple ones involving a single timeline and asingle
scene. The objects have been either shapes, instances of graphic symbols, or text. In Flash 5,
where actions take place not only on different layers but in different scenes and even in
different timelines in movie clips.
CREATING SYMBOLS AND MOVIE CLIPS
A symbol is a reusable element residing in the flash library or in the current movie library.
Every time you uses the same symbol. Flash Creates an instance of the original symbol. Thus,
symbols reduce the file size of your movie as Flash saves only the original symbols. All the
instances are only reference to the original symbol. There are three types of symbols available
in flash namely, Button Symbols, Graphics Symbols and Movie Clips.
Button Symbol
It is used for creating action buttons. Button symbol has four states based on mouse state
namely, up, down, over and hit. To create a button perform the following steps:
1 Select New Symbol option from the insert menu. Once you have selected new symbol
option. Symbol Properties dialog box is displayed as shown below:
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2

5

Assign the Name to the Button symbol in the Name textbox and select the type of symbol
you want to create from Behaviour Radio button. In the case, we will select Buttons,
radio button option. Click on OK button to close the Symbol properties dialog box.
After you have configured the Symbol properties, the Symbol Editing Window appears
on screen as shown in figure given below. All the four states for the button are also
displayed in the window.
To create the Up state button image, use the drawing tools, import a graphic, or place an
instance of another symbol on the Stage. You can use a graphic or movie clip symbol in a
button, but you cannot use another button in the button. Use a movie clip symbol if you
want the button to be animated.
Click the second frame, labelled over, and choose insert > keyframe.

6

Change the button image or color of the button for the Over state.

3

4

7 Repeat steps 5 and 6 for the Down frame and the Hit frame.
8 The Hit frame is not visible on the Stage, but it defines the area of the button that
responds when clicked. Make sure that the graphic for the Hit frame is a solid area large
enough to encompass all the graphic elements of the Up, Down, and Over frames.
9 When you’ve finished, choose Edit > Edit Movie. Drag the button symbol out of the Library
window to create an instance of it in the movie.
TO CREATE A NEW SYMBOL WITH SELECTED ELEMENTS:
1 Select an element or
several elements on
the Stage and choose
Insert > Convert to
Symbol.
2 In
the
Symbol
Properties dialog box,
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type the name of the
symbol and choose the
behaviour---Graphic,
Button, or Movie Clip.
3 Click OK
1 Select an element or several elements on the Stage and choose Insert > Convert to
Symbol.
4 In the Symbol Properties dialog box, type the name of the symbol and choose the
behaviour---Graphic, Button, or Movie Clip.
5 Click OK.
ADDING SYMBOLS IN MOVIE CLIPS
After learning the process of creating different symbols, let us now learn how to all symbol
to the movie. To add a symbol to a movie perform the following steps:
1. Select the type of symbol (button, advanced, graphics, movie clips and sounds) that you
want to add to your movie using the Window option available in the Library menu.
2. After you have selected the symbol type, the Library window for the same is displayed.
Then you can select from the different type of symbols available under your selected
symbol type.
3. Drag the symbol from the Library and Drop the same on to the stage.
EDITING SYMBOLS
Each instance of a symbol is a copy of the original symbol. You can edit this instance
according to your requirements. You can edit the symbols in different ways such as:
1. Editing the symbol in symbol edit mode (Edit).
2. Editing the symbol in a new window (Edit in New Window).
3. Editing a symbol in place (Edit in New Window).
To edit symbol, select the same and right click on it. A pop-up menu will be displayed as shown
in above fig. Using which you can select the edit option and edit the symbol accordingly.
To edit symbol from the Library without instancing it, open the library using the Library using
the Library option from the Window menu. Select the symbol and then double click on it to
edit the same. Please note that through this mode you can edit only your own created
symbols. You have several choices when entering the symbol editing mode:
1. EDIT: The stage is cleaned and all you see is our object to edit. Choose Edit/Edit symbol
or Edit/Edit Selected from the menu bar, choose Edit from the context menu, or Press
Ctrl+E on the key board.
2. Edit in Place All of the other object are dimmed but still visible and you edit your object
in the contest of the other objects. However, the coordinates and timeline are those of
the MC and not the main timeline.
3. Edit in New Window. All editing takes places in a separate window off the stage. The
object appears in the upper-left corner of the new window (X=0, Y=0). Select Edit in
New Window from the context menu.
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SOUND FILE
Flash provides different sound effects such as sound fade-in and fade-out. You can play
sounds continuously independent of the Timeline or can synchronize animation to a sound
track. Your can attach sounds to action or simple buttons to make them more responsive.
Flash offer two types of sounds----- event sounds and stream sounds. An event sound must be
downloaded completely before it starts playing. But it has to be explicitly stopped. Stream
sounds starts playing as soon as enough data for this first few frames has been downloaded
and synchronize the sound to the Timeline. To add sound to your movie first create a layer
and then assign sound to it. You can set options in the Sound panel of the Frame Properties
dialog box.
SOUND FILE TYPE
Three popular typers of sound files are used with a Flash 5 movie:
WAV: Pronounced “wave,” this is the name of the waveform sound files jointly developed by
Microsoft and IBM for Windows.
AIFF: Audio Interchange File Format was created by Apple Computer. Inc., for Macintosh
computers.
MP3: The most efficient and effective sound file compression is based on MPEG (Moving
Picture Expert Group) Audio Layer 3, or MP3.
TO ADD A SOUND TO A MOVIE:
1 Import the sound if it has not already been imported.
To Import the sound:
2 Choose File > Import.
3 In the Import dialog box, locate and open the desired sound file.
The imported sound is placed in the library for the current movie.
4 Choose Insert > Layer to create a layer for the sound.
5 With the new sound layer selected, drag the sound from the library onto the Stage.
The sound is added to the current layer. You can place multiple sounds on one layer, or
on layers containing other objects. However, it is recommended that each sound be
placed on a separate layer. Each layer acts like a separate sound channel. The sound on
all layers ae combined when you play back the movie.
6 Choose Window > Panels > Sound.
7 In the Sound panel, choose a sound file
8 Choose an effect option from the Effects pop-up menu:
None applies no effects to the sound file. Choose this option to remove previously
applied effects. Left Channel/Right Channel plays sound in the left or right channel only.
Fade Left to Right/Fade Right to Left shifts the sound from one channel to the other
Fade.
It gradually increases the amplitude of a sound over its duration. Fade Out gradually
deceases the amplitude of a soundover its duration. Custom lets you create your own
In and Out points of sound using the Edit Envelope.
NOTE: If you use an MP3 sound as a stream sound, you must recompress the sound for
export.
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9 Enter a value for Loop to specify the number of times the sound should loop. For
continuous play, enter a number large enough to play the sound for an extended
duration. For example, to loop a 15-second sound for 15 minutes, enter 60.
SOUND SOURCE ON THE WEB
The Web is filled with sources for different sounds. Most of the sound sources are free, but
some stipulate that you cannot use the sound for commercial purposes.
Most of Flash users know enough to type “WAV” or “AIFF” into a search engine. You will find
literally millions of Web sites that way. These sites have a good collection of WAV and / or AIFF
files:
www.flashsound.com
www.flahkit.com
www.music4flash.com
www.flash-sounds.com
FLASH AND HTML
When the user incorporate Flash contents in the web site, to be able to open or run the same
in a browser, HTML document has to be opened first. The HTML document in turn activates
the Flash player and run the movie.
You can play a Flash Player movie:
In an Internet Browser such as Netscape Navigator, Internet Explorer.
In application like Director as a part of Quick Time movie or as a Standalone application called
projector.
You can use the Publish command to create the files required to create Flash web application.
The Publish feature of Flash enables you to incorporate your flash movie in web page HTML
code. You can include Flash movies in the HTML code either automatically with the help of
Publish option under the File menu or can add the movies manually by defining <OBJECT> and
<EMBED> tags in the HTML files.
HTML Tags: To be able to display your Flash Player movie in a web browser, an HTML
document must use the EMBED and OBJECT tags with the proper parameters.
<OBJECT> TAG In OBJECT tag, the user can configure four settings:
HEIGHT
WIDTH
CLASSID,
CODEBASE
All the other parameters can be defined in a separate tag category named PARAM tags.
For example:
<object classid = “clsid:d27cdb6e-ae6d-11cf-96b8-444553540000”
width=”100” height =”100”
Codebase=
“http://active.macromedia.com/flash5/cabe/swflash.cab#version=5,0,0,0”>
<param name=”movie”value=”mymovie.swf”>
<param
name
=
“pay”
value =
“true”>
<param name = “loop” value = “true”>
<param name = “quality “ value =”high”>
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</object>
<EMBED> TAG
For the EMBED tag, all the attribute setting (such as HEIGHT,WIDTH,QUALITY and LOOP)
appear between the angle brackets
For example:
<embed src=“btn.swf” width=”100” height=”100” play = “true”
loop=”true” quality= “high”
pluginspage.=”http://
www.macromedia.com/shockwave/download/index.cgi?P1_Prod_version=shockwaveFlash”
>
</embed>
During the publish process. Flash inserts the Public Setting parameters in template you select
in HTML panel. A template is a text file that includes special variable beginning with a dollar
sign($)
Flash substitutes the appropriate value for each template variable. A template can be any
text file containing the appropriate template variable.
To use both OBJECT and EMBED tags together, position the EMBED tag just before the closing
OBJECT tag as incorporated in the following code:
<HTML>
<HEAD>
<TITLE>ABC</TITLE>
</HEAD>
<BODY>
<OBJECT classid=”clsid:D27CDB6E-AB6D-11CF-96B8-44553540000”
ID=btn WIDTH = 550 HEIGHT – 400>
<PARAM NAME=movie VALUE=”abc.swf”>
<PARAM NAME=quality VALUE=high>
<PARAM NAME=bgcolor VALUE=#336633>
<EMBED src=”abc.swf” quality=high bgcolor=#336633 width = 550
HEIGHT=400 TYPE=”application/ x-shock wave-flash”
rod_Version=shockwaveflash”>
<EMBED></OBJECT></BODY></HTML>
To publish HTML for displaying the Flash File:
1 Choose File>Publish Settings
The HTML file type is selected by default.
2 Enter a unique name for Filename, or select Use Default Name to Create a file with the
Flash file name plus the html extension.
3 Click the HTML panel to display its settings.
4 Choose an installed template to use from the Template pop-up menu: click the Info
button to the right to display a description of the selected template.
5 Choose a Dimensions option to set the values of the WIDTH and HEIGHT attributes in
the OBJECT and EMBED tags:
Choose Match Movie (the default) to use the size of the movie.
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Choose Pixels to enter the number of pixels in the Width and Height field.
Choose Percent to use a percentage relative to the browser window.
6 For the Windows version of Internet Explorer 4.0 with the Flash Active X control, choose
a Window Mode option for transparency, positioning and Hayering. This option
specifies the ALIGH attribute for the OBJECT, EMBED, and IMG tags.
7 Choose an HTML Alignment option to position the Flash movie window within the
browser window.
8 To save the settings with the current file,click OK.
ASSIGNMENT
1. Flash offer how many types of Sounds. What do you understand by Sound in Flash?
2. Write all the steps to add Sounds in a movie
3. How will you use Flash in HTML ?
4. Write steps to Publish Flash movie in HTML.
MACHINE ROOM SESSION
1. Create a movie with two action buttons. When the user press on the First Button it
starts the movie and when user press an another button then it stops the whole movie.
2. 2 Create a movie and incorporate the same in your web page using Publish option as
well as writing the HTML code yourself. Also prepare a distribution Copy with the help
of Flash Player.

UNIT 4
NETWORK
 A network is interconnection between computer and various devices.
 Combination of many networks is called as internet. Network devices can be connected to
With cables or without cables
 Why do we need a network?
 To share hardware and software resources.
 Cost effective
 It is reliable
 Fastest and cheapest way of communication.
 Protocols: It is a set of rules through which computers in a network can communicate with
each other.
Inside Internet
1. Network: It is a group of interconnected computers and devices.
These may be connected by a cable or wireless.
2. Internet : It is a network of networks i.e. it is a group of interconnected networks.
3. Protocols : It is a set of rules, through which computers in a network can communicate with
each other’s. Ex:
a. TCP

: Transmission control protocol

b. IP

: Internet Protocol
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c. HTTP : Hyper text transfer protocol.
4. Search Engine: It is a software which is used to search for a document or a file in world
wide web (www). Ex. Google, yahoo.
5. Browser : It is a software which is used to navigate or move through the web pages. It also
helps in displaying the web page. E.g. google chrome, Firefox, internet explorer,
Netscape navigator, safari (apple safari) etc.
Q. Why do we need a network?
Ans. We need a network because.
 It is used to share hardware and software resources, for example a single printer is sufficient
for a network of forty (40) computers.


Since, all the resources can be shared to a network is very cost effective.



If a system crashes, then the files and documents present on it can be accessed through any of
the computers in a network. So, a network is reliable.

 It is the cheapest and fastest medium of communication across the globe.
Q. Describe different types of network?
Ans. There are 3 types of network
a. LAN : Local Area Network: It is a group of interconnected computers and devices; spread over
a small area. For example a room, building or a campus. If the network is connected without
cables, then it is called as WLAN (wireless LAN)
b. MAN (Metropolitan Area Network): it is a combination of many groups of LANS. Eg. Cable TV
network.
c. WAN (Wide Area Network): It is the group of many LANs and MANs. It spans entire cities and
countries. Eg. www.internet etc
R. Network devices

a. Amplifier: It is a network device which strengthens the data signals along with noises
(disturbances)
b. Repeater: It is a network device which repeats the data signal without any noises.
c. Router: It is a network device which sends the data packets through the shortest and safest
route to the destination computers.
d. Gateway : It is a network device that connects two dissimilar networks.
e. Client: The user’s computer or the computer that sends request for information is called the
client computer.
f. Server: It is a powerful computer that serves the requests of the client.
g. MODEM: It stands for: Modulator / Demodulator
The modulator converts digital signals to electronic signal. And the demodulators present at
the destination computers converts these electronic signals back to digital signals.
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Q How does T.C.P/ IP work?
Ans.
The TCP present at the source computer breaks down the large data into small data packets.
The IP then carries these data packets through the shortest and safest route to the destination
computer. The TCP at the destination computer re-orders the data packets and displays it to the user.
This is also known as packet switching.
a. UPS : (uninterrupted power supply) It is an electrical equipment used to protect the servers
and clients from power disruptions.
b. FIREWALL: A firewall rescues a network from un-authorised connections made to a computer
or a network. We have both hardware firewall and software firewall.
c. Data security: It is used to protect the data from being mishandled by unauthorized users. Eg.
Using passwords: thumb impressions; voice mail etc.
d. Data Privacy: The process of keeping a part of a data hidden from the rest of the users is called
data privacy.
e. Encryption: It is the process of converting data into a form that cannot be easily understood
by
unauthorized people.
f. Decryption: It is the process of converting encrypted data back into its original from, so that
it
can be understood.
g. Cipher : It is the code or algorithm to encrypt or decrypt the data.
h. Key: It Is a secret to the cipher: Known only to authorized people.
i. HTTP: (Hyper text tanfer protocol) It provides encrypted communication between a client and
the web server. It is usally used where sensitive information is needed. For
eg. Payment transactions on the internet.
j. ISP : (Internet Service Provider): Companies or organisations that provides internet services
to a customer are called ISP’s . Eg: vodaphone, reliance, idea, jio, airtel etc.
Q. A cipher is given below with an example study it and answer the following.
a. Encrypt your name using the cipher.
Decrypt using the given cipher.
1

2

3

4

5

1

A

B

C

D

E

2

F

G

H

I/J

K

3

L

M

N

O

P

4

Q

R

S

T

U

5

V

W

X

Y

Z

Eg:
a. Mrs. Nupur ( 33 54 53 54 24 )
b. Dhani
( 14 23
1 33 24 )
c. Computer ( 33 43 23 54 34 44 52 24 )
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R. Make a cipher on your own.
a. Enter your name using a cipher ; DHANI
Write a message using a cipher:
HI! HOW ARE YOU

ANS A.
B.

1

2

3

4

5

1

Y

W

X

Y

Z

2

Q

R

H

T

U

3

K/L

M

N

O

P

4

F

G

H

I

J

5

A

B

C

D

E

44
12

51

22

54 43
43 44

51
43

33
34

55

14

34
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Q Fill in the blanks
a. To set up networks; network cables; client, server and switch are used.
b. In a network; resources such as file and printer can be shared.
c. A wireless LAN uses radio signal to connect computers.
d. A network set up in a small office is LAN
e. Internet is an example of WAN.
f. A powerful computer that provides a service; such as centralized files storage is
called as servers.
g. A computer that connects to the internet, to send mails is called a client
h. Web sites that transfer information securely use HTTPS, so that the information is
encrypted.
i. A firewall is used to protect a computer from unauthorized use.

Photoshop
1. Introduction to Adobe Photoshop
Adobe Photoshop is a popular image editing software that provides a work environment consistent
with Adobe Illustrator, Adobe InDesign, Adobe Photoshop and other products in the Adobe Creative
Suite. This tutorial is an introduction to using Adobe Photoshop. Here you will learn how to get started,
how to use the interface, and how to modify images with basic editing skills.
1.1. Setting up the document
Setting up your document correctly from the start will make your job much easier as you work through
your project. This will require some advanced planning. For example, if your final output will be a
brochure, you may need to set up your document to be horizontal and double-sided.
To create a new document, click File > New. This will open the Document Setup dialog box
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Here you will be able to name your file, set up the correct page size and orientation for your document.
Options include, but are not limited to:
Page Size and Orientation
Change the page size by typing in new values for width and height. Page size represents the final size
you want after bleeds or trimming other marks outside the page. In the Preset dropdown menu you
can find such common sizes as letter, legal, tabloid, etc. Typing in exact values for Height and Width
Gives you more control over the size and orientation of your page.
Resolution
Resolution is the number of pixels on a printed area of an image. The higher the resolution, the more
pixels there are on the page, the better the quality of the image. However, high resolution increases
the size of the file. The standard recommended resolution for printed images is 150-300, for Web
images it is 72.
Color Mode
Choose a color mode that will best fit your project. For example, when making a graphic for a web
site, choose RGB. When making an image for print choose CMYK.
Background Contents
Choose the background: white, color or transparent. When you have entered all of your document
settings, click Ok.
Opening an image from a disk
If the image you have is saved on a disk or to the computer, select File > Open, and then navigate to the
disk drive/file where your image is saved. Choose the image file and click Open. At this point, you may
want to save your image under a different name so that you can always have the original to fall back on
in case of a mistake.
To save your file, select File > Save As and type in the new name of the file in the dialogue box.
1.2. Interface Layout
Menu Bar :- If you look at the top of the screen you will see the Menu bar, which contains all the main
functions of Photoshop, such as File, Edit, Image, Layer, Select, Filter, Analysis, 3D, View, Window, and
Help.
Toolbar :- Most of the major tools are located in the Toolbar for easy access.
The Image :-The image will appear in its own window once you open a file.
Image Name
The name of any image that you open will be at the top of the image window as shown above.
2. Working with Palettes and Drawing guide
2.1 Palettes
Palettes contain functions that help you monitor and modify images. By default, palettes are
stacked
together in groups. These are the palettes that are usually visible: Color, Adjustments and
Layers. If
none of the palettes are visible, go to Window in the Menu bar and choose the palettes you need.
Below is the description of the most commonly used palettes in Adobe Photoshop. Palettes used for
more advanced image editing will be covered in the Adobe Photoshop.
Color, Swatches, Style
The Color palette displays the current foreground and background colors and RGB values for these
colors. You can use the sliders to change the foreground and background colors in different color modes.
You can also choose a color from the spectrum of colors displayed in the color ramp at the bottom of
the palette.
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Color palette

In the Swatches palette you can choose a foreground or background color and add a customized color
to the library.

Swatches palette

The Styles palette allows you to view, select, and apply preset layer styles. By default, a preset style
replaces the current layer style. You can use the styles in the palette or add your own using the Create
New Style icon.

Styles
History
The History palette stores and displays each action performed allowing you jump to any recent stage of
the image alteration. The alterations should be created during the current working session. After saving
or closing the document, the History palette clears all the contents. Each time you apply a change to an
image, the new state of that image is added to the palette. It is important to know that once you click on
any of the previous stages, all the changes that were made after it will be lost.

History palette
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Adjustments
The Adjustment layers palette give you the ability to apply an effect to a group of layers in Photoshop,
and then you can edit that effect later, while preserving the original layers.

Adjustments palette
Layers
Layers let you organize your work into distinct levels that can be edited and viewed as individual units.
Every Photoshop CS6 document contains at least one layer. Creating multiple layers lets you easily
control how your artwork is printed, displayed, and edited. You will use the Layers palette often while
creating a document, so it is crucial to understand what it does and how to use it.
Layer Visibility -The eye shows that the selected layer is visible. Click on or off to see or to hide a layer.
Layer Locking Options -Click the checkered square icon to lock Transparency, click the brush icon to
lock the Image, click the arrow icon to lock the Position, and click the lock icon to lock all options.
Layer Blending Mode -Defines how the layer’s pixels blend with underlying pixels in the image. By
choosing a particular blending mode from the drop-down menu you can create a variety of special
effects. D) Fill -By typing in a value or dragging the slider you can specify the transparency.
Opacity -By typing in a value or dragging the slider, you can specify the transparency of the entire layer.

Layer palette
Layer Lock -The icon shows when the layer is locked and disappears when it is unlocked. Double-click
the icon to unlock the layer.
Layer Options Menu -Click the black triangle to display the following options: New Layer, Duplicate
Layer, Delete Layer, Layer Properties, etc. Some of the options are presented as icons at the bottom of
the Layers palette.
Link Layers – Can be used to link layers together.

Layer Styles -If a layer has a style, an “F” icon shows at the bottom of the Layers palette. Click the little
black triangle to see style options.
Layer Mask -Allows you to hide certain parts of the layer, which can then be revealed by using the
paintbrush and the white paint color to expose portions of the layer.
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Layer Set -This option helps to organize images with multiple layers. Click the icon to create a folder for
several layers.
Create New Fill or Adjustment Layer -Have the same opacity and blending mode options as image layers
and can be rearranged, deleted, hidden and duplicated in the same manner as image layers. Click the
icon and select an option to create a new fill or adjustment layer.
Create New Layer -Click this icon to create a new layer.
Delete Layer -To delete a layer, select a layer in the Layers palette and drag it to the trash can icon, or
select a layer and click the icon.
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2.2. Drawing Guide

Toolbox

3. Basic Image Manipulation and colour basics
3.1 Basic Image Manipulation
Now that you know how to find your way around in the Adobe Photoshop interface and are familiar
with the most common commands, palettes, and tools, you can start doing some basic image editing. In
the next few chapters of this tutorial you will learn how to crop, resize, correct, and sharpen/blur your
images.
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3.1.1 Cropping Image
Cropping is one of the most basic editing techniques that can improve your images. Cropping helps to
bring out the most important features in your image and focus the viewers’ attention on these features.
Cropping also allows you to make your image a standard photo size.
There are several ways to crop images in Adobe Photoshop:
 Cropping with the Crop Tool
 Cropping to a specific size
 Cropping with the Marquee Tool
 Cropping with the Crop Tool
The Crop Tool allows you to make a precise selection of an image you wish to edit. To crop with the
Crop Tool, follow these steps:
 Open the image you wish to crop (see Getting Started for detailed instructions).
 Select the Crop Tool from the Toolbox (see Selection Tools for location and description).
 It will automatically select your entire image. Drag the edges to fit the dimensions you desire.
 Resize the border by dragging the squares at the sides and corners until you are satisfied with
the way your image looks.
Once you are completely satisfied with your cropped image, press Enter.
Note: You can also rotate your cropping border. Move the cursor outside the border, you will see how
it turns into a double-headed arrow. Drag the arrows in the directions you wish to rotate your selection.
Cropping to a specific size
If you wish to print your digital photos or other images on standard size photo paper, you will have to
crop your images to a specific size, such as 8x10. To crop an image to a specific size, do the following:
 Open the image you wish to crop.
 Select the Crop Tool from the Toolbox.
 In the Options bar, specify the values for Width and Height.
 Click in your image and drag the cropping border.
Notice that the border is constrained. You cannot
make it wider or longer than the specified
values. For example, if you entered 8 for Width and 10 for Height, whatever size you make the border,
the area within it will fit on an 8x10 photo. Once you are completely satisfied with your cropped image,
press Enter.
Cropping with the Marquee Tool
If you are in a hurry and need just a simple crop, you can use the Marquee Tool and a menu command.
To crop with the Marquee Tool, follow the steps below:
 Open the image you wish to crop.
 Select the Rectangular Marquee Tool from the Toolbox.
 Click and drag the mouse to draw a marquee around the area you wish to crop.
 In the main menu, go to Image > Crop (Figure 16). The image will be immediately cropped.
3.1.2 Resizing
Resizing in Photoshop can help you print your images in standard photo sizes, resize and preserve the
high quality of digital photos, and enlarge small images to a poster size.

Resizing to a specific size
To resize your image to a preset size, follow the steps below:
 In the main menu, go to File > New.
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In the New dialog box, click on the Preset dropdown menu. You will see several preset sizes, such
as 2x3, 4x6 and 5x7. Remember that 72 ppi is fine for online images, but a ppi of 150-300 is
better for printed images.
 Choose the size that you wish and click OK.
Note: All the preset sizes are in portrait orientation. If you wish to resize an image with the landscape
orientation, you need to create your own preset.
To create your own size, do the following:
 Type in the values for Width and Height, for example 7x5.
 Type in your desired resolution (150 ppi for high quality prints, and 72 ppi is good for web
images).
 Click the Save Preset button
Resizing digital photos
Digital photos usually have large dimensions but low resolution, 72 ppi, which affects their quality when
their size is decreased or increased. When printed, the photos with the changed size will look pixilated.
To resize the digital photos without loosing the quality, follow these steps:
 Open the digital photo you wish to resize.
 In the main menu, go to View > Rulers. You will see the dimension of your photo.
 In the main menu, go to Image > Image Size.
 In the Image Size dialog box, check the Resample Image box off Type in your desired resolution
(anything between 150 and 300 ppi). The photo is now 3.208 x 3.083 inches.
3.1.3 Enlarging
If you want to make your digital photo into a poster size image, you can do it in the Image Size dialog
box. However, just increasing the dimensions will make the image appear blurry and pixilated. To
enlarge the image without losing the quality, follow these steps:
 Open the digital image you wish to enlarge.
 In the main menu, go to Image > Image Size.
 In the Image Size dialog box, make sure the Resample Image box is checked off and choose
Bicubic Smoother from the dropdown box .
 Change the Document Size measurements to Percent. Type in 110. This will increase the size of
the image by 10 percent (Figure 20).
 Continue enlarging by 10 percent until you are satisfied with the size.

3.1.4 Correcting
Digital cameras tend to cause various problems, such as “red eye” or “hot spots”, if you use flash, or
underexposure, if you don’t. In Photoshop, you can correct these problems, as well as adjust the overall
color of your digital photo.
3.1.5 Red Eye Removal
The digital camera flash is located right above the lens, which causes the “red-eye”; however, you can
fix your photos easily in Photoshop. To remove the “red eye”, follow the steps below:
 Open a photo you wish to correct.
 Select the Zoom Tool from the Toolbox. Click and drag a rectangle around the eye.
 Make sure your default Foreground and Background colors are black and white.
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Click and hold on the little black triangle of the Healing Brush Tool button and select the Red Eye
Tool.
Click on the red part of the eye and paint, holding down the mouse button. You will see how the
red
will disappear

3.1.6 Hot Spot Removal
Using a flash can also cause shiny areas on peoples’ faces or the flash to reflect on shiny surfaces. To
correct this problem, follow the steps below:
 Open the photo you wish to correct.
 Select the Clone Stamp Tool from the Toolbox.
 In the Options bar, change the Blend Mode from Normal to Darken
 Set the Opacity to 50 percent.
 Choose a soft-edged brush, set the diameter to 40 or 50.
 Hold down the Shift key and click in the clean area (without “hot spots”) to get a sample of color
 Paint over the “hot spot”, the light area will gradually darken.

3.1.7 Adding Flash
If you took pictures indoors without a flash, they will turn out underexposed and dark. To fix
underexposed photos, follow these steps:
 Open a digital photo you wish to correct
 In the main menu, go to Layers > Duplicate. In the next window, name the layer Layer 1.
 Make sure Layer 1 is selected in the Layers palette. Select Image from the menu, select
Adjustments and select Exposure. Select the amount of exposure. The whole image will lighten.
 Keep duplicating Layer 1 until you are satisfied with your image.
3.1.8 Color Adjustment
Color adjustment options in Photoshop CS6 can help you to make your digital photos look more natural.
To color correct your images, follow these steps:






Open the image you wish to correct.
In the main menu, go to Image > Adjustments > Levels. You will see a dialog box displaying a
diagram of the colors in your image. The black triangle is for shadows, the gray is for mid tones,
the white is
for highlights. In the Channels dropdown menu, you can choose between RGB. These indicate
whether your changes effect all the colors, or just one (red, green, or blue).
Make sure the Preview box is checked off. Choose the channel you wish to change and drag the
triangles. Dragging the black triangle to the right will make the shadows in your photo darker.
Dragging the white triangle to the left will make the highlights in your photo lighter, and
dragging it to the right will make the mid tones darker. You will be able to see the changes in
your image. By correcting the highlights and making the image lighter, we are able to make the
photo appear much brighter.

3.1.9. Saving
Remember to save your work often. Saving frequently lessens the risk of losing the work you have been
doing.
To save your Photoshop document, do the following:
 Click File > Save As.
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Navigate to the place you would like your document to be saved by using the drop down menu
and the navigation window.
 Enter the name of your document in the Save As text field.
 Choose a format to save your project in from the Format drop-down menu.
 Click the Save button in the bottom right corner of the dialogue box.
 Check to make sure that your document is saved in the place you intended.
Note: If you save your file as PSD (default Photoshop saving format) your layers will be preserved, but
the file size will be large. If you save your file as JPEG (a common image format) your layers will be
flattened and become one layer, and the file size will be significantly smaller.
3.2 Colour Basics
3.2.1. Understanding color
Knowing how colors are created and how they relate to each other lets you work more effectively in
Photoshop. Instead of achieving an effect by accident, you’ll produce consistent results thanks to an
understanding of basic color theory.
Primary colors
Additive primaries are the three colors of light (red, green, and blue) that produce all the colors in the
visible spectrum when added together in different combinations. Adding equal parts of red, blue, and
green light produces white. The complete absence of red, blue, and green light results in black.
Computer monitors are devices that use the additive primaries to create color.

Additive colors (RGB)A.
( Red B. Green C. Blue )
Secondary Colors
Subtractive primaries are pigments, which create a spectrum of colors in different combinations. Unlike
monitors, printers use subtractive primaries (cyan, magenta, yellow, and black pigments) to produce
colors through subtractive mixing. The term “subtractive” is used because the primary colors are pure
until you begin mixing them together, resulting in colors that are less pure versions of the primaries.
For example, orange is created through the subtractive mixing of magenta and yellow together.

Subtractive colors (CMYK)
(A. Cyan B. Magenta C. Yellow D. Black )
3.2.2. The color wheel
If you’re new to adjusting color components, it helps to keep a standard color wheel diagram on hand
when you work on color balance. You can use the color wheel to predict how a change in one color
component affects other colors and also how changes translate between RGB and CMYK color models.
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Color
(A. Red B. Yellow C. Green D. Cyan E. Blue F. Magenta)

wheel

For example, you can decrease the amount of any color in an image by increasing the amount of its
opposite on the color wheel—and vice versa. Colors that lie opposite each other on the standard color
wheel are known as complementary colors. Similarly, you can increase and decrease a color by adjusting
the two adjacent colors on the wheel, or even by adjusting the two colors adjacent to its opposite.
In a CMYK image, you can decrease magenta either by decreasing the amount of magenta or by
increasing its complement, which is green (the color on the opposite side of the color wheel from
magenta). In an RGB image, you can decrease magenta by removing red and blue or by adding green.
All of these adjustments result in an overall color balance containing less magenta.
3.2.3 Color models, spaces, and modes
A color model describes the colors we see and work with in digital images. Each color model,
such as RGB, CMYK, or HSB, represents a different method (usually numeric) for describing color.
A color space is a variant of a color model and has a specific gamut (range) of colors. For example, within
the RGB color model are a number of color spaces: Adobe RGB, RGB, ProPhoto RGB, and so on.
Each device, like your monitor or printer, has its own color space and can only reproduce colors in its
gamut. When an image moves from one device to another, image colors may change because each device
interprets the RGB or CMYK values according to its own color space. You can use color management
when moving images to ensure that most colors are the same or similar enough so they appear
consistent.
In Photoshop, a document’s color mode determines which color model is used to display and
print the image you’re working on. Photoshop bases its color modes on the color models that are useful
for images used in publishing. You can choose from RGB (Red, Green, Blue), CMYK (Cyan, Magenta,
Yellow, Black), Lab Color (based on CIE L* a* b*), and Grayscale. Photoshop also includes modes for
specialized color output such as Indexed Color and Duotone. Color modes determine the number of
colors, the number of channels, and the file size of an image. Choosing a color mode also determines
which tools and file formats are available.
When you work with the colors in an image, you are adjusting numerical values in the file. It’s
easy to think of a number as a color, but these numerical values are not absolute colors in themselves—
they only have a color meaning within the color space of the device that is producing the color.
3.2.4 Adjust color hue, saturation, and brightness
Based on the human perception of color, the HSB model describes three fundamental characteristics of
color:

Hue
Color reflected from or transmitted through an object. It is measured as a location on the standard color
wheel, expressed as a degree between 0° and 360°. In common use, hue is identified by the name of the
color, such as red, orange, or green.
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Saturation
Strength or purity of the color (sometimes called chroma). Saturation represents the amount of gray in
proportion to the hue, measured as a percentage from 0% (gray) to 100% (fully saturated). On the
standard color wheel, saturation increases from the center to the edge.
Brightness
Relative lightness or darkness of the color, usually measured as a percentage from 0% (black) to 100%
(white).

HSB color m
(A. Hue B. Saturation C. Brightness )
4. Painting tools and brush setting
The Brush tool allows you to paint on any layer, much like a real paintbrush. You'll also have
different settings to choose from, which can help you customize it for different situations. Once you
know how to use the Brush tool, you'll notice that many other tools, including the Eraser and the Spot
Healing Brush, use a similar group of settings.
4.1 Using the Brush tool
It's easy to use the Brush tool to paint in your document. Simply locate and select the Brush tool from
the Tools panel, then click and drag in the document window to paint. You can also press the B key on
your keyboard to select the Brush tool at any time.

To choose a different brush color, click the top-most color in the Color Picker Tool (this is known as
the Foreground Color), then select the desired color from the dialog box.

You'll also be able to customize different settings for the Brush tool from the Control panel near the top
of the screen.
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4.2 Some of the settings you can adjust here include:
4.2.1 Brush Size: If you want to make the brush larger or smaller, click the Brush Picker drop-down
arrow in the Control panel, then adjust the Size slider. You can also press the bracket keys [ ] to quickly
increase or decrease the brush size at any time
4.2.2. Hardness: If you want to make the edges of the brush harder or softer, you can adjust
the hardness from the same drop-down menu. A harder brush will have clear, defined edges, whereas
a softer brush will have blurry, less-defined edges. For most situations, we recommend setting the
hardness to 50% or less because it will help to make individual brush strokes less obvious.
4.2.3. Brush Tip: If you want to create a unique effect, there are different brush tips to choose from
in the same drop-down menu. Some of these are designed to mimic real-life drawing tools like pens and
markers, while others are simpler.
4.2.4. Opacity: By default, the opacity of your brush is set to 100%, meaning the brush will use the
highest intensity. However, you can reduce the opacityof your brush to make it less intense.
4.2.5. Other tools that use Brush settings
As we mentioned above, many other tools work in a similar way. For example, if you select
the Eraser tool, you can click and drag in the document window to erase parts of the selected layer. You
can fine-tune the Eraser tool by adjusting the size, hardness, opacity, and more from the Control
panel.
5. Making selections and filling strokes.
5.1. Making selections
In Adobe Photoshop, you can make selections based on size, shape, and color using four basic
sets of tools—the marquee, lasso, magic wand, and pen tools. In addition, you can use a fifth tool, the
move tool, to reposition the selections you create.
Note: In this lesson, you will use just the marquee, lasso, magic wand, and move tools; for more information
on the pen tools, see Chapter 7, “Selecting,” in the Adobe Photoshop User Guide.

A. Marquee Tool B. Move Tool C. Lasso Tool D. Magic Wand Tool
The marquee and lasso tool icons contain hidden tools, which you can select by holding down the mouse
button on the toolbox icon and dragging to the desired tool in the pop-up menu.
5.1.1 The rectangular marquee tool ( ) lets you select a rectangular area in an image. The elliptical
marquee tool ( ) lets you select elliptical areas. The single row and single column marquee tools ( ) ( )
let you select a 1-pixel-high row and 1-pixel-wide column. You can also use the crop tool ( ) to crop an
image.
5.1.2. The lasso tool ( ) lets you make a freehand selection around an area. The polygon lasso tool (
) lets you make a straight-line selection around an area. The magnetic lasso tool ( ) lets you draw a
freehand border that snaps to the edges of an area.
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5.1.3. The magic wand tool ( ) lets you select parts of an image based on the similarity in color of
adjacent pixels. This tool is useful for selecting odd-shaped areas without having to trace a complex
outline using the lasso tool.
5.2. Stroke (outline) objects on a layer
You can use the Stroke command to automatically trace a colored outline around a selection or the
content of a layer.
Note:
To add an outline to the background, you must first convert it to a regular layer. The background contains
no transparent pixels, so the entire layer is outlined.
Select the area in the image or a layer in the Layers panel.
Choose Edit > Stroke (Outline) Selection.
In the Stroke dialog box, set any of the following options, and then click OK to add the outline:
Width
Specifies the width of the hard-edged outline. Values can range from 1 to 250 pixels.
Color
Sets the color of the outline. Click the color swatch to select a color in the Color Picker.
Location
Specifies whether to place the outline inside, outside, or centered over the selection or layer boundaries.
Mode
Specifies how the paint that you apply blends with the existing pixels in the image.
Opacity
Sets the opacity of the paint you apply. Enter an opacity value or click on the arrow and drag the slider.
Preserve Transparency
Strokes only areas containing opaque pixels on a layer. If your image has no transparency, this option
isn’t available.
6. Working with Multiple Layers
About layers
Photoshop layers are like sheets of stacked acetate. You can see through transparent areas of a layer
to the layers below. You move a layer to position the content on the layer, like sliding a sheet of
acetate in a stack.
You can also change the opacity of a layer. Transparent areas on a layer let you see layers below.
You use layers to perform tasks such as compositing multiple images, adding text to an image, or
adding vector graphic shapes. You can apply a layer style to add a special effect such as a drop shadow
or a glow.
Organizing layers
A new image has a single layer. The number of additional layers, layer effects, and layer sets you can
add to an image is limited only by your computer’s memory.
Layers panel overview
The Layers panel lists all layers, layer groups, and layer effects in an image. You can use the Layers
panel to show and hide layers, create new layers, and work with groups of layers. You can access
additional commands and options in the Layers panel
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Photoshop Layers panel
A. Layers panel menu B. Layer Group C. Layer D. Expand/Collapse Layer effects
Layer thumbnail

E. Layer effect F.

Display the Layers panel
Choose Window > Layers.
Choose a command from the Layers panel menu
 Click the triangle in the upper right corner of the panel.
 Change the size of layer thumbnails
 Choose Panel Options from the Layers panel menu, and select a thumbnail size.
 Change thumbnail contents
Convert background and layers
When you create a new image with a white background or a colored background, the bottommost
image in the Layers panel is called Background. An image can have only one background layer. You
cannot change the stacking order of a background layer, its blending mode, or its opacity. However,
you can convert a background into a regular layer, and then change any of these attributes.
When you create a new image with transparent content, the image does not have a background layer.
The bottommost layer is not constrained like the background layer; you can move it anywhere in the
Layers panel and change its opacity and blending mode.
Convert a background into a layer
 Double-click Background in the Layers panel, or choose Layer > New > Layer From
Background.
 Set layer options.
 Click OK.
Convert a layer into a background
 Select a layer in the Layers panel.
 Choose Layer > New > Background from Layer.
 Any transparent pixels in the layer are converted to the background color, and the layer drops
to the bottom of the layer stack.
Create layers and groups
A new layer appears either above the selected layer or within the selected group in the Layers panel.
 To create a new layer or group using default options, click the Create a New Layer button or
New Group button in the Layers panel.
 Choose Layer > New > Layer or choose Layer > New > Group.
 Choose New Layer or New Group from the Layers panel menu.
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Alt-click (Windows) or Option-click (Mac OS) the Create a New Layer button or New Group
button in the Layers panel to display the New Layer dialog box and set layer options.
 Ctrl-click (Windows) or Command-click (Mac OS) the Create a New Layer button or New Group
button in the Layers panel to add a layer below the currently selected layer.
 Set layer options, and click OK.
Name Specifies a name for the layer or group.
Create a layer from an existing file
 Drag the file icon from Windows or Mac OS onto an open image in Photoshop.
 Move, scale, or rotate the imported image.
 Press Enter or Return.

Create a layer with effects from another layer
 Select the existing layer in the Layers panel.
 Drag the layer to the Create a New Layer button at the bottom of the Layers panel. The newly
created layer contains all the effects of the existing one.
 Convert a selection into a new layer
Make a selection.
 Do one of the following:
 Choose Layer > New > Layer Via Copy to copy the selection into a new layer.
 Choose Layer > New > Layer Via Cut to cut the selection and paste it into a new layer.
Note: You must rasterize Smart Objects or shape layers to enable these commands.
Duplicate layers
 Drag the layer or group to the Create a New Layer button
.
 Choose Duplicate Layer or Duplicate Group from the Layers menu or the Layers panel menu.
 Enter a name for the layer or group, and click OK.
Show or hide a layer, group, or style
 Click the eye icon next to a layer, group, or layer effect to hide its content in the document
window. Click in the column again to redisplay the content. To view the eye icon for styles and
effects, click the Reveal Effects in panel icon.
 Choose Show Layers or Hide Layers from the Layers menu.
 Alt-click (Windows) or Option-click (Mac OS) an eye icon to display only the contents of that
layer or group. Photoshop remembers the visibility states of all layers before hiding the
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